R1#
R1#
interface Loopback0
ip address 192.168.10.254 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0.0.0.0
network 192.168.10.0 0.0.0.255 area 0.0.0.0
!
R1#
R2#
R2#
interface Loopback0
ip address 192.168.1.126 255.255.255.128
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0.0.0.0
network 192.168.1.0 0.0.0.127 area 0.0.0.0
!
R2#
R2#
R3#
R3#
interface Loopback0
ip address 192.168.1.254 255.255.255.128
!
interface FastEthernet0/0
ip address 10.1.1.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0.0.0.0
network 192.168.1.128 0.0.0.127 area 0.0.0.0
!
R3#
R3#
//-----------------------------------------------------//
R1#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.10.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
192.168.1.0/32 is subnetted, 2 subnets
O 192.168.1.126 [110/11] via 10.1.1.2, 05:12:51, FastEthernet0/0
O 192.168.1.254 [110/11] via 10.1.1.3, 05:11:25, FastEthernet0/0
R1#
R1#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
192.168.1.126 1 FULL/BDR 00:00:32 10.1.1.2 FastEthernet0/0
192.168.1.254 1 FULL/DROTHER 00:00:34 10.1.1.3 FastEthernet0/0
R1#
R1#
R2#
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/32 is subnetted, 1 subnets
O 192.168.10.254 [110/11] via 10.1.1.1, 05:15:20, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/25 is directly connected, Loopback0
O 192.168.1.254/32 [110/11] via 10.1.1.3, 05:13:52, FastEthernet0/0
R2#
R2#
R2#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
192.168.1.254 1 FULL/DROTHER 00:00:39 10.1.1.3 FastEthernet0/0
192.168.10.254 1 FULL/DR 00:00:33 10.1.1.1 FastEthernet0/0
R2#
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.10.0/32 is subnetted, 1 subnets
O 192.168.10.254 [110/11] via 10.1.1.1, 05:18:34, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
O 192.168.1.126/32 [110/11] via 10.1.1.2, 05:18:34, FastEthernet0/0
C 192.168.1.128/25 is directly connected, Loopback0
R3#
R3#
R3#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
192.168.1.126 1 FULL/BDR 00:00:39 10.1.1.2 FastEthernet0/0
192.168.10.254 1 FULL/DR 00:00:33 10.1.1.1 FastEthernet0/0
R3#
沒有留言:
張貼留言