2013年8月9日 星期五

EIGRP and OSPF Redistribution


This LAB objective is EIGRP and OSPF Redistribution , R1 router has learning EIGRP and OSPF route , R1 router will redistribution R2's EIGRP route into OSPF network , and redistribution R3's OSPF route into EIGRP netowrk , follow is the LAB command.



EIGRP redistribute command
redistribute ospf 10 metric 1500 1 255 1 1   
1500 : EIGRP bandwidth metric in kbits per second
 1 : EIGRP delay metric, in 10 microsecond units
255 : EIGRP reliability metric where 255 is 100% reliable
1 :  EIGRP Effective bandwidth metric (Loading) where 255 is 100% loaded
1 :  EIGRP MTU of the path


OSPF redistribute command
 redistribute eigrp 10 metric-type 1 subnets
metric-type 1 : OSPF exterior metric type 1 for redistributed route
subnets : Consider subnets for redistributed into OSPF


R1#
===============================
interface Serial1/0
 ip address 192.168.2.1 255.255.255.0
!
interface Serial1/1
 ip address 192.168.1.1 255.255.255.0
!
router eigrp 10
 redistribute ospf 10 metric 1500 1 255 1 1   
 network 192.168.2.0
 no auto-summary
!
router ospf 10
 log-adjacency-changes
 redistribute eigrp 10 metric-type 1 subnets
 network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
===============================


R2#
===============================
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback2
 ip address 172.16.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.2.2 255.255.255.0
!
router eigrp 10
 network 172.16.1.0 0.0.0.255
 network 172.16.2.0 0.0.0.255
 network 192.168.2.0
 no auto-summary
!
===============================


R3#
===============================
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.1.2.2 255.255.255.0
!
interface Serial1/1
 ip address 192.168.1.2 255.255.255.0
!
router ospf 10
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0.0.0.0
 network 10.1.2.0 0.0.0.255 area 0.0.0.0
 network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
===============================



R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS

level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static

route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
D       172.16.1.0 [90/2297856] via 192.168.2.2, 22:02:38, Serial1/0
D       172.16.2.0 [90/2297856] via 192.168.2.2, 22:02:38, Serial1/0
     10.0.0.0/32 is subnetted, 2 subnets
O       10.1.2.2 [110/65] via 192.168.1.2, 06:59:24, Serial1/1
O       10.1.1.1 [110/65] via 192.168.1.2, 06:59:24, Serial1/1
C    192.168.1.0/24 is directly connected, Serial1/1
C    192.168.2.0/24 is directly connected, Serial1/0
R1#




R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS

level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static

route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, Loopback0
C       172.16.2.0 is directly connected, Loopback2
     10.0.0.0/32 is subnetted, 2 subnets
D EX    10.1.2.2 [170/2218752] via 192.168.2.1, 01:53:31, Serial1/0
D EX    10.1.1.1 [170/2218752] via 192.168.2.1, 01:53:31, Serial1/0
D EX 192.168.1.0/24 [170/2218752] via 192.168.2.1, 01:53:31, Serial1/0

C    192.168.2.0/24 is directly connected, Serial1/0
R2#
R2#
R2#


R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS

level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static

route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
O E1    172.16.1.0 [110/84] via 192.168.1.1, 06:09:04, Serial1/1
O E1    172.16.2.0 [110/84] via 192.168.1.1, 06:09:04, Serial1/1

     10.0.0.0/24 is subnetted, 2 subnets
C       10.1.2.0 is directly connected, Loopback1
C       10.1.1.0 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Serial1/1
O E1 192.168.2.0/24 [110/84] via 192.168.1.1, 06:09:04, Serial1/1
R3#
R3#


2013年8月4日 星期日

EGIRP Unequal Cost Load Balance




==========================
Before enable EIGRP unequal cost load ablance
==========================

In R1 router EIGRP topology table ,  routing  to 172.16.1.0/24  network , least cost Feasible Distance is : 3651840  serial 1/1,  it is best route.

Now we want to  enable EIGRP unequal cost load balance.

The variance value :   second least cost FD < least cost  FD*variance
                                     61519363 < 3651840*variance , 
                                     variance=2

R1#sh ip route eigrp
     172.16.0.0/24 is subnetted, 1 subnets
D       172.16.1.0 [90/3651840] via 192.168.2.2, 00:00:47, Serial1/1    [only the best route]     192.168.4.0/30 is subnetted, 1 subnets
D       192.168.4.0 [90/3523840] via 192.168.2.2, 00:00:47, Serial1/1
     192.168.3.0/30 is subnetted, 1 subnets
D       192.168.3.0 [90/4035840] via 192.168.2.2, 00:00:47, Serial1/1
R1#



R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(10)/ID(10.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.1.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 192.168.1.0/30, 1 successors, FD is 5511936
        via Connected, Serial1/0
P 192.168.2.0/30, 1 successors, FD is 3011840
        via Connected, Serial1/1
P 192.168.3.0/30, 1 successors, FD is 4035840
        via 192.168.2.2 (4035840/3523840), Serial1/1
        via 192.168.1.2 (6023936/3011840), Serial1/0
P 192.168.4.0/30, 1 successors, FD is 3523840
        via 192.168.2.2 (3523840/3011840), Serial1/1
P 172.16.1.0/24, 1 successors, FD is 3651840
        via 192.168.2.2 (3651840/3139840), Serial1/1
        via 192.168.1.2 (6151936/3139840), Serial1/0
R1#


==========================
After enable EIGRP unequal cost load ablance
==========================


R1(config)#router eigrp 10
R1(config-router)#variance 2

we can see the second route has show in the routing table.



R1#show ip route eigrp
     172.16.0.0/24 is subnetted, 1 subnets
D       172.16.1.0 [90/3651840] via 192.168.2.2, 00:00:57, Serial1/1   [best route]
                           [90/6151936] via 192.168.1.2, 00:00:57, Serial1/0    [second route] 
     192.168.4.0/30 is subnetted, 1 subnets
D       192.168.4.0 [90/3523840] via 192.168.2.2, 00:00:57, Serial1/1
     192.168.3.0/30 is subnetted, 1 subnets
D       192.168.3.0 [90/4035840] via 192.168.2.2, 00:00:57, Serial1/1
                              [90/6023936] via 192.168.1.2, 00:00:57, Serial1/0
R1#

show the routing table to 172.17.1.0/24 prefix , we can see the interface , traffic share count and network bandwidth.



R1#show ip route 172.16.1.0
Routing entry for 172.16.1.0/24
  Known via "eigrp 10", distance 90, metric 3651840, type internal
  Redistributing via eigrp 10
  Last update from 192.168.1.2 on Serial1/0, 00:07:48 ago
  Routing Descriptor Blocks:
  * 192.168.2.2, from 192.168.2.2, 00:07:48 ago, via Serial1/1
      Route metric is 3651840, traffic share count is 120
      Total delay is 45000 microseconds, minimum bandwidth is 1024 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2
    192.168.1.2, from 192.168.1.2, 00:07:48 ago, via Serial1/0
      Route metric is 6151936, traffic share count is 71
      Total delay is 45000 microseconds, minimum bandwidth is 512 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

R1#



All router configuration :

R1#
==========================
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Serial1/0
 bandwidth 512
 ip address 192.168.1.1 255.255.255.252
!
interface Serial1/1
 bandwidth 1024
 ip address 192.168.2.1 255.255.255.252
!
router eigrp 10
 variance 2
 network 10.1.1.0 0.0.0.255
 network 192.168.1.0 0.0.0.3
 network 192.168.2.0 0.0.0.3
 no auto-summary
!

==========================



R2#
==========================

interface Serial1/0
 bandwidth 512
 ip address 192.168.1.2 255.255.255.252
!
interface Serial1/1
 bandwidth 1024
 ip address 192.168.3.1 255.255.255.252
!

router eigrp 10
 network 192.168.1.0 0.0.0.3
 network 192.168.3.0 0.0.0.3
 no auto-summary
! 

==========================


R3#
==========================
interface Serial1/0
 bandwidth 1024
 ip address 192.168.4.1 255.255.255.252
!
interface Serial1/1
 bandwidth 1024
 ip address 192.168.2.2 255.255.255.252
!
router eigrp 10
 network 192.168.2.0 0.0.0.3
 network 192.168.4.0 0.0.0.3
 no auto-summary
! 

==========================



R4#
==========================interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial1/0
 bandwidth 1024
 ip address 192.168.4.2 255.255.255.252
 serial restart-delay 0
!
interface Serial1/1
 bandwidth 1024
 ip address 192.168.3.2 255.255.255.252
 serial restart-delay 0
!



router eigrp 10
 network 172.16.1.0 0.0.0.255
 network 192.168.3.0 0.0.0.3
 network 192.168.4.0 0.0.0.3
 no auto-summary
==========================