2015年2月9日 星期一










OSPF totally stub LAB


Router portland  should not receive any external or inter area route , only receive default route.  Router Lynaic can learning all OSPF route.


Complete configuration
=====================================
Portland#sh run
Building configuration...

Current configuration : 1117 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Portland
!
interface Serial1/0
 ip address 192.168.4.5 255.255.255.252
!
router ospf 1
 log-adjacency-changes
 area 1 stub
 network 192.168.4.4 0.0.0.3 area 1
!
Portland#  
=====================================
Amani#sh run
!
hostname Amani
!
interface Serial1/0
 ip address 192.168.72.6 255.255.255.252
!
interface Serial1/1
 ip address 192.168.4.6 255.255.255.252
!
router ospf 1
 log-adjacency-changes
 area 1 stub no-summary
 network 192.168.4.4 0.0.0.3 area 1
 network 192.168.72.4 0.0.0.3 area 0
!
Amani#    
=====================================
Lynaic#sh run
!
hostname Lynaic    
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial1/1
 ip address 192.168.72.5 255.255.255.252
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 2
 network 192.168.72.4 0.0.0.3 area 0
!
Lynaic#
=====================================



Portland#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.4.6 to network 0.0.0.0

     192.168.4.0/30 is subnetted, 1 subnets
C       192.168.4.4 is directly connected, Serial1/0
O*IA 0.0.0.0/0 [110/65] via 192.168.4.6, 00:53:28, Serial1/0
Portland#


=====================================


Lynaic#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.72.0/30 is subnetted, 1 subnets
C       192.168.72.4 is directly connected, Serial1/1
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     192.168.4.0/30 is subnetted, 1 subnets
O IA    192.168.4.4 [110/128] via 192.168.72.6, 00:54:11, Serial1/1
Lynaic#
=====================================

Amani#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.72.0/30 is subnetted, 1 subnets
C       192.168.72.4 is directly connected, Serial1/0
     1.0.0.0/32 is subnetted, 1 subnets
O IA    1.1.1.1 [110/65] via 192.168.72.5, 01:07:22, Serial1/0
     192.168.4.0/30 is subnetted, 1 subnets
C       192.168.4.4 is directly connected, Serial1/1
Amani#
=====================================

EIGRP stub and summary LAB







EIGRP stub and summary route LAB


1. Use EIGRP protocol , config router R3 can communicate to R2 network prefix
2. config router R3 only learning summary route 10.0.0.0/16



Before summary route
===================================
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 8 subnets
D       10.2.8.0 [90/2300416] via 10.2.3.4, 00:37:11, Serial1/0
D       10.2.9.0 [90/2300416] via 10.2.3.4, 00:37:11, Serial1/0
D       10.2.2.0 [90/2172416] via 10.2.3.4, 00:37:11, Serial1/0
C       10.2.3.0 is directly connected, Serial1/0
D       10.2.4.0 [90/2300416] via 10.2.3.4, 00:37:11, Serial1/0
D       10.2.5.0 [90/2300416] via 10.2.3.4, 00:37:11, Serial1/0
D       10.2.6.0 [90/2300416] via 10.2.3.4, 00:37:11, Serial1/0
D       10.2.7.0 [90/2300416] via 10.2.3.4, 00:37:11, Serial1/0
R3#
R3#
R3#


After summary route
===================================
R3#
*Feb  9 12:53:14.255: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 10.2.3.4 (Serial1/0) is resync: peer graceful-restart
R3#
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       10.2.0.0/16 [90/2172416] via 10.2.3.4, 00:00:05, Serial1/0
C       10.2.3.0/24 is directly connected, Serial1/0
R3#

Complete config
===========================================
R3#sh run
!
hostname R3    
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.2.3.3 255.255.255.0
!
router eigrp 123
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
 eigrp stub connected summary
!
R3# 
===========================================
R4#sh run
!
hostname R4
!
interface FastEthernet0/0
 ip address 10.2.2.4 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.2.3.4 255.255.255.0
 ip summary-address eigrp 123 10.2.0.0 255.255.0.0 5
!
router eigrp 123
 network 10.0.0.0
 no auto-summary
!
R4#
===========================================
R2#sh run
!
hostname R2
!
interface Loopback0
 ip address 10.2.4.2 255.255.255.0
!
interface Loopback1
 ip address 10.2.5.2 255.255.255.0
!
interface Loopback2
 ip address 10.2.6.2 255.255.255.0
!
interface Loopback3
 ip address 10.2.7.2 255.255.255.0
!
interface Loopback4
 ip address 10.2.8.2 255.255.255.0
!
interface Loopback5
 ip address 10.2.9.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.2.2.2 255.255.255.0
!
router eigrp 123
 network 10.0.0.0
 no auto-summary
!  
R2#
===========================================