2017年2月5日 星期日

OSPF Totally NSSA area





R1#
R1#show run
Building configuration...
!
hostname R1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.1.2.1 255.255.255.0
!
interface Loopback2
 ip address 10.1.3.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.0.1 255.255.255.252
!
interface Serial1/1
 ip address 192.168.1.1 255.255.255.252
!         
router ospf 1
 area 1 nssa no-summary
 redistribute static subnets
 network 10.1.1.0 0.0.0.255 area 0
 network 10.1.2.0 0.0.0.255 area 0
 network 10.1.3.0 0.0.0.255 area 0
 network 192.168.0.0 0.0.0.3 area 1
 network 192.168.1.0 0.0.0.3 area 0
!
line con 0
line vty 0 4       
!
end

R1#   
R1#
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C        10.1.1.0/24 is directly connected, Loopback0
L        10.1.1.1/32 is directly connected, Loopback0
C        10.1.2.0/24 is directly connected, Loopback1
L        10.1.2.1/32 is directly connected, Loopback1
C        10.1.3.0/24 is directly connected, Loopback2
L        10.1.3.1/32 is directly connected, Loopback2
O N2     10.2.1.0/24 [110/1] via 192.168.0.2, 00:08:37, Serial1/0
O N2     10.2.2.0/24 [110/1] via 192.168.0.2, 00:08:37, Serial1/0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/30 is directly connected, Serial1/0
L        192.168.0.1/32 is directly connected, Serial1/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, Serial1/1
L        192.168.1.1/32 is directly connected, Serial1/1
      192.168.2.0/30 is subnetted, 1 subnets
O N2     192.168.2.0 [110/1] via 192.168.0.2, 00:08:37, Serial1/0
S     200.200.200.0/24 [1/0] via 192.168.1.2

R1#   

(Stub area and totally Stub area can not redistribution other protocol route)


// Normal Area
R2#
R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O IA     10.1.1.1/32 [110/65] via 192.168.0.1, 00:00:03, Serial1/0
O IA     10.1.2.1/32 [110/65] via 192.168.0.1, 00:00:03, Serial1/0
O IA     10.1.3.1/32 [110/65] via 192.168.0.1, 00:00:03, Serial1/0
R        10.2.1.0/24 [120/1] via 192.168.2.2, 00:00:06, Serial1/1
R        10.2.2.0/24 [120/1] via 192.168.2.2, 00:00:06, Serial1/1
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/30 is directly connected, Serial1/0
L        192.168.0.2/32 is directly connected, Serial1/0
      192.168.1.0/30 is subnetted, 1 subnets
O IA     192.168.1.0 [110/128] via 192.168.0.1, 00:00:03, Serial1/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/30 is directly connected, Serial1/1
L        192.168.2.1/32 is directly connected, Serial1/1
O E2  200.200.200.0/24 [110/20] via 192.168.0.1, 00:00:03, Serial1/0
R2#   
R2#


// NSSA Area
R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O IA     10.1.1.1/32 [110/65] via 192.168.0.1, 00:00:05, Serial1/0
O IA     10.1.2.1/32 [110/65] via 192.168.0.1, 00:00:05, Serial1/0
O IA     10.1.3.1/32 [110/65] via 192.168.0.1, 00:00:05, Serial1/0
R        10.2.1.0/24 [120/1] via 192.168.2.2, 00:00:12, Serial1/1
R        10.2.2.0/24 [120/1] via 192.168.2.2, 00:00:12, Serial1/1
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/30 is directly connected, Serial1/0
L        192.168.0.2/32 is directly connected, Serial1/0
      192.168.1.0/30 is subnetted, 1 subnets
O IA     192.168.1.0 [110/128] via 192.168.0.1, 00:00:05, Serial1/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/30 is directly connected, Serial1/1
L        192.168.2.1/32 is directly connected, Serial1/1
O N2  200.200.200.0/24 [110/20] via 192.168.0.1, 00:00:05, Serial1/0
R2#  



// Totally NSSA  Area

R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/65] via 192.168.0.1, 00:00:35, Serial1/0
      10.0.0.0/24 is subnetted, 2 subnets
R        10.2.1.0 [120/1] via 192.168.2.2, 00:00:14, Serial1/1
R        10.2.2.0 [120/1] via 192.168.2.2, 00:00:14, Serial1/1
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/30 is directly connected, Serial1/0
L        192.168.0.2/32 is directly connected, Serial1/0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/30 is directly connected, Serial1/1
L        192.168.2.1/32 is directly connected, Serial1/1
O N2  200.200.200.0/24 [110/20] via 192.168.0.1, 00:00:35, Serial1/0
R2#  
R2#


R2#  
R2#
R2#sh run
Building configuration...
!
hostname R2
!interface Serial1/0
 ip address 192.168.0.2 255.255.255.252
!         
interface Serial1/1
 ip address 192.168.2.1 255.255.255.252
!
router ospf 1
 area 1 nssa no-summary
 redistribute rip metric 1 subnets
 network 192.168.0.0 0.0.0.3 area 1
!
router rip
 version 2
 redistribute ospf 1 metric 1
 network 192.168.2.0
 no auto-summary  
!
line con 0
line vty 0 4
!
end

R2#  

R3#
R3#
R3#sh run
Building configuration...
!
hostname R3
!
interface Loopback0
 ip address 200.200.200.200 255.255.255.0
!
interface Serial1/1
 ip address 192.168.1.2 255.255.255.252
!
ip route 10.1.0.0 255.255.0.0 192.168.1.1
ip route 10.2.0.0 255.255.0.0 192.168.1.1
ip route 192.168.0.0 255.255.0.0 192.168.1.1
!
line con 0
line vty 0 4
!
end

R3#   


R3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/16 is subnetted, 2 subnets
S        10.1.0.0 [1/0] via 192.168.1.1
S        10.2.0.0 [1/0] via 192.168.1.1
S     192.168.0.0/16 [1/0] via 192.168.1.1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, Serial1/1
L        192.168.1.2/32 is directly connected, Serial1/1
      200.200.200.0/24 is variably subnetted, 2 subnets, 2 masks
C        200.200.200.0/24 is directly connected, Loopback0
L        200.200.200.200/32 is directly connected, Loopback0
R3# 




R4#sh run
Building configuration...
!
hostname R4
!
interface Loopback0
 ip address 10.2.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.2.2.1 255.255.255.0
!
interface Serial1/1
 ip address 192.168.2.2 255.255.255.252
!
router rip
 version 2
 redistribute ospf 1
 network 10.0.0.0
 network 192.168.2.0
 no auto-summary
!
line con 0
line vty 0 4
!
end

R4#   

R4#
R4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.2.1 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 192.168.2.1, 00:00:19, Serial1/1
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.2.1.0/24 is directly connected, Loopback0
L        10.2.1.1/32 is directly connected, Loopback0
C        10.2.2.0/24 is directly connected, Loopback1
L        10.2.2.1/32 is directly connected, Loopback1
      192.168.0.0/30 is subnetted, 1 subnets
R        192.168.0.0 [120/1] via 192.168.2.1, 00:00:19, Serial1/1
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/30 is directly connected, Serial1/1
L        192.168.2.2/32 is directly connected, Serial1/1
R     200.200.200.0/24 [120/1] via 192.168.2.1, 00:00:19, Serial1/1
R4#
R4#




沒有留言:

張貼留言