2013年6月25日 星期二

EIGRP over Frame Relay MultiPoint and Point-to-Point Subinterface




==================================================
hostname R1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.104 point-to-point
 ip address 172.16.1.1 255.255.255.252
 frame-relay interface-dlci 104  
!
interface Serial1/0.123 multipoint
 ip address 10.1.1.1 255.255.255.0
 no ip split-horizon eigrp 100
 frame-relay map ip 10.1.1.3 103 broadcast
 frame-relay map ip 10.1.1.2 102 broadcast
!
router eigrp 100
 network 1.1.1.1 0.0.0.0
 network 10.1.1.0 0.0.0.255
 network 172.16.1.0 0.0.0.3
 no auto-summary
!
==================================================


==================================================
hostname R2
!
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.1 point-to-point
 ip address 10.1.1.2 255.255.255.0
 frame-relay interface-dlci 201  
!
router eigrp 100
 network 1.1.1.2 0.0.0.0
 network 10.1.1.0 0.0.0.255
 no auto-summary
!
==================================================


==================================================
hostname R3
!
interface Loopback0
 ip address 1.1.1.3 255.255.255.255
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.1 point-to-point
 ip address 10.1.1.3 255.255.255.0
 frame-relay interface-dlci 301  
!
router eigrp 100
 network 1.1.1.3 0.0.0.0
 network 10.1.1.0 0.0.0.255
 no auto-summary
!
==================================================



==================================================
hostname B1
!
interface Loopback0
 ip address 1.1.1.4 255.255.255.255
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.104 point-to-point
 ip address 172.16.1.2 255.255.255.252
 frame-relay interface-dlci 401  
!
router eigrp 100
 network 1.1.1.4 0.0.0.0
 network 172.16.1.0 0.0.0.255
 no auto-summary
!
==================================================




 
 *************************************************************************** 
 ***************************************************************************
R1 show info :
ping 1.1.1.2
ping 1.1.1.3
ping 1.1.1.4
show frame-relay lmi
show frame-relay map
show frame-relay pvc
show ip eigrp neignbors
show ip eigrp topology
show ip route

*************************************************************************** 
***************************************************************************


 
R1#
R1#
R1#sh ip eigrp nei
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   172.16.1.2              Se1/0.104         14 01:04:36 1264  5000  0  3
1   10.1.1.3                Se1/0.123         13 11:09:29  244  1464  0  9
0   10.1.1.2                Se1/0.123         13 11:12:10  227  1362  0  12
R1#
R1#
R1#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       1.1.1.0/24 is directly connected, Loopback0
D       1.1.1.3/32 [90/2297856] via 10.1.1.3, 11:01:18, Serial1/0.123
D       1.1.1.2/32 [90/2297856] via 10.1.1.2, 11:11:43, Serial1/0.123
D       1.1.1.4/32 [90/2297856] via 172.16.1.2, 01:04:41, Serial1/0.104
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial1/0.104
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial1/0.123
R1#
R1#
R1#
R1#sh frame-relay map
Serial1/0.123 (up): ip 10.1.1.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial1/0.123 (up): ip 10.1.1.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active
Serial1/0.104 (up): point-to-point dlci, dlci 104(0x68,0x1880), broadcast
          status defined, active
R1#
R1#
R1#
R1#
R1#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.123

  input pkts 9653          output pkts 913          in bytes 825276
  out bytes 64691          dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 731       out bcast bytes 46784
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 1d06h, last time pvc status changed 1d06h

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.123

  input pkts 9536          output pkts 890          in bytes 802189
  out bytes 62599          dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 731       out bcast bytes 46784
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 1d06h, last time pvc status changed 1d06h

DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.104

  input pkts 991           output pkts 1162         in bytes 83281
  out bytes 152989         dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 1127      out bcast bytes 149363
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 1d06h, last time pvc status changed 1d06h
R1#
R1#
R1#
*************************************************************************** 
***************************************************************************


*************************************************************************** 
***************************************************************************
R2 show info :
ping 1.1.1.1
ping 1.1.1.3
ping 1.1.1.4
show frame-relay lmi
show frame-relay map
show frame-relay pvc
show ip eigrp neignbors
show ip eigrp topology
show ip route
R2#
R2#
R2#
R2#show frame-relay map
Serial1/0.1 (up): point-to-point dlci, dlci 201(0xC9,0x3090), broadcast
          status defined, active
R2#
R2#
R2#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

  input pkts 916           output pkts 9684         in bytes 64883
  out bytes 827798         dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 9500      out bcast bytes 809750
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 12:31:47, last time pvc status changed 12:30:47
R2#
R2#
R2#
R2#
R2#
R2#
R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.1.1                Se1/0.1          162 11:14:56  418  2508  0  26
R2#
R2#
R2#
R2#
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       1.1.1.0/24 [90/2297856] via 10.1.1.1, 11:14:34, Serial1/0.1
D       1.1.1.3/32 [90/2809856] via 10.1.1.1, 09:33:45, Serial1/0.1
C       1.1.1.2/32 is directly connected, Loopback0
D       1.1.1.4/32 [90/2809856] via 10.1.1.1, 01:07:23, Serial1/0.1
     172.16.0.0/30 is subnetted, 1 subnets
D       172.16.1.0 [90/2681856] via 10.1.1.1, 01:07:26, Serial1/0.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial1/0.1
R2#
R2#
R2#
R2#
R2#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/71/136 ms
R2#ping 1.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
R2#ping 1.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/126/248 ms
R2#ping 1.1.1.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/104/216 ms
R2#
R2#
R2#
R2#
R2#

*************************************************************************** 
***************************************************************************




*************************************************************************** 
***************************************************************************
R3 show info :
ping 1.1.1.1
ping 1.1.1.2
ping 1.1.1.4
show frame-relay lmi
show frame-relay map
show frame-relay pvc
show ip eigrp neignbors
show ip eigrp topology
show ip route
 
R3#
R3#show frame-relay map
Serial1/0.1 (up): point-to-point dlci, dlci 301(0x12D,0x48D0), broadcast
          status defined, active
R3#
R3#
R3#
R3#show frame
R3#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

  input pkts 907           output pkts 9626         in bytes 64087
  out bytes 809694         dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 9460      out bcast bytes 793202
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 11:37:06, last time pvc status changed 11:36:06
R3#
R3#
R3#
R3#
R3#
R3#
R3#sh ip eig
R3#sh ip ei
R3#sh ip eigrp nei
R3#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.1.1                Se1/0.1          162 11:15:48  684  4104  0  26
R3#
R3#
R3#
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       1.1.1.0/24 [90/2297856] via 10.1.1.1, 11:15:49, Serial1/0.1
C       1.1.1.3/32 is directly connected, Loopback0
D       1.1.1.2/32 [90/2809856] via 10.1.1.1, 09:37:18, Serial1/0.1
D       1.1.1.4/32 [90/2809856] via 10.1.1.1, 01:10:56, Serial1/0.1
     172.16.0.0/30 is subnetted, 1 subnets
D       172.16.1.0 [90/2681856] via 10.1.1.1, 01:10:58, Serial1/0.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial1/0.1
R3#
R3#
R3#
R3#
R3#
R3#sh ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(1.1.1.3)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 1.1.1.0/24, 1 successors, FD is 2297856
        via 10.1.1.1 (2297856/128256), Serial1/0.1
P 1.1.1.3/32, 1 successors, FD is 128256
        via Connected, Loopback0
P 1.1.1.2/32, 1 successors, FD is 2809856
        via 10.1.1.1 (2809856/2297856), Serial1/0.1
P 1.1.1.4/32, 1 successors, FD is 2809856
        via 10.1.1.1 (2809856/2297856), Serial1/0.1
P 10.1.1.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/0.1
P 172.16.1.0/30, 1 successors, FD is 2681856
        via 10.1.1.1 (2681856/2169856), Serial1/0.1
R3#
R3#
R3#
*************************************************************************** 
***************************************************************************




*************************************************************************** 
***************************************************************************
B1 show info :
ping 1.1.1.1
ping 1.1.1.2
ping 1.1.1.3
show frame-relay lmi
show frame-relay map
show frame-relay pvc
show ip eigrp neignbors
show ip eigrp topology
show ip route
 
B1#show frame-relay map
Serial1/0.104 (up): point-to-point dlci, dlci 401(0x191,0x6410), broadcast
          status defined, active
B1#
B1#
B1#
B1#
B1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 401, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.104

  input pkts 1008          output pkts 1052         in bytes 86152
  out bytes 88469          dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 1012      out bcast bytes 84551
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:14:43, last time pvc status changed 01:13:43
B1#
B1#
B1#
B1#
B1#
B1#
B1#
B1#
B1#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.1.1              Se1/0.104         13 01:09:03  137   822  0  25
B1#
B1#
B1#
B1#
B1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       1.1.1.0/24 [90/2297856] via 172.16.1.1, 01:09:04, Serial1/0.104
D       1.1.1.3/32 [90/2809856] via 172.16.1.1, 01:09:04, Serial1/0.104
D       1.1.1.2/32 [90/2809856] via 172.16.1.1, 01:09:04, Serial1/0.104
C       1.1.1.4/32 is directly connected, Loopback0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial1/0.104
     10.0.0.0/24 is subnetted, 1 subnets
D       10.1.1.0 [90/2681856] via 172.16.1.1, 01:09:04, Serial1/0.104
B1#
B1#
B1#
B1#
B1#
B1#
B1#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/78/144 ms
B1#ping 1.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 148/188/232 ms
B1#ping 1.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/116/268 ms
B1#
B1#
B1#
*************************************************************************** 
***************************************************************************







 



























2013年6月6日 星期四

Security Basic Password Authentication

Security Basic Password Authentication


0.setting enable secret password

1.setting console password:ciscoconsole

2.setting vty(virtual type terminal) password for telnet or ssh :ciscovty


-----------------------------------------------------------------------------
1.
Router>
Router>en
Router#config
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#
Router(config)#enable secret cisco
Router(config)#
Router(config)#line console 0
Router(config-line)#password ciscocon
Router(config-line)#login
Router(config-line)#end

%SYS-5-CONFIG_I: Configured from console by console
Router#
Router#
Router#exit


User Access Verification

Password:

Router>
-----------------------------------------------------------------------------

2.
R1#
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int fa0/0
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#exit
R1(config)#line vty 0 4
R1(config-line)#password ciscovty
R1(config-line)#login
R1(config-line)#exit
R1(config)#end
R1#


//------------------------------------
PC: ip address 10.1.1.10/24
//------------------------------------


PC>telnet 10.1.1.1
Trying 10.1.1.1 ...Open


User Access Verification

Password:
Router>en
Password:
Router#
Router#
-----------------------------------------------------------------------------





Security Local User Database Authentication

Security Local User Database Authentication



Router#
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#
Router(config-if)#
Router(config-if)#no sh
Router(config-if)#
Router(config-if)#
Router(config-if)#ip add 10.1.1.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#
Router(config)#
Router(config)#username jerry privilege 15 secret abc
Router(config)#username barry privilege 1 secret abc
Router(config)#
Router(config)#enable secret cisco
Router(config)#
Router(config)#
Router(config)#line vty 0 4
Router(config-line)#login local
Router(config-line)#exit
Router(config)#

---------------------------------------------

C:\Users\lin>telnet 10.1.1.1

User Access Verification

Username: jerry
Password:
Router#
Router#

---------------------------------------------
C:\Users\lin>telnet 10.1.1.1

User Access Verification

Username: barry
Password:
Router>
Router>
---------------------------------------------

Security SSH Router Config

Security SSH Router Config



Router#
Router#
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#
R1(config)#int fa0/0
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#no sh
Router(config)#username jerry privilege 15 secret abc
Router(config)#
Router(config)#hostname R1
R1(config)#ip domain-name sshtest.com
R1(config)#crypto key generate rsa
The name for the keys will be: R1.sshtest.com
Choose the size of the key modulus in the range of 360 to 2048 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

R1(config)#
R1(config)#ip ssh version 2
R1(config)#
R1(config)#line vty 0 4
R1(config-line)#transport input ssh
R1(config-line)#login local


//-------------------------------
  Switch to your PC
//-------------------------------
login as: jerry
Using keyboard-interactive authentication.
Password:

R1#
R1#
R1#







2013年6月5日 星期三

WAN PPP Auth use PAP

WAN PPP Auth use PAP


R1#
username user1 password 0 abc1

interface Serial0/0
 no shutdown
 ip address 10.1.1.1 255.255.255.252
 encapsulation ppp
 clock rate 2000000
 ppp authentication pap
 ppp pap sent-username user2 password 0 abc2

R1#


R2#
username user2 password 0 abc2

interface Serial0/0
 no shutdown
 ip address 10.1.1.2 255.255.255.252
 encapsulation ppp
 clock rate 2000000
 ppp authentication pap
 ppp pap sent-username user1 password 0 abc1

R2#


WAN PPP Auth use CHAP

WAN PPP Auth use CHAP

R1#
username R2 password 0 abc

interface Serial0/0
 ip address 10.1.1.1 255.255.255.252
 encapsulation ppp
 clock rate 2000000
 ppp authentication chap
!
R1#


R2#
username R1 password 0 abc

interface Serial0/0
 ip address 10.1.1.2 255.255.255.252
 encapsulation ppp
 clock rate 2000000
 ppp authentication chap
R2#



WAN Frame Relay Point-to-Point subinterface

WAN Frame Relay Point-to-Point subinterface























R1#
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
!
interface Serial0/0.102 point-to-point
 ip address 192.168.3.1 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 102
!
interface Serial0/0.103 point-to-point
 ip address 192.168.1.1 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 103

R1#


R2#
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
!
interface Serial0/0.201 point-to-point
 ip address 192.168.3.2 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 201
!
interface Serial0/0.203 point-to-point
 ip address 192.168.4.1 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 203
R2#


R3#
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
!
interface Serial0/0.301 point-to-point
 ip address 192.168.1.2 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 301
!
interface Serial0/0.302 point-to-point
 ip address 192.168.4.2 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 302
R3#


//-------------------------------------------//


R1#sh frame-relay map
Serial0/0.102 (up): point-to-point dlci, dlci 102(0x66,0x1860), broadcast
          status defined, active
Serial0/0.103 (up): point-to-point dlci, dlci 103(0x67,0x1870), broadcast
          status defined, active
R1#



R1#sh frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          2            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.102

  input pkts 24            output pkts 40           in bytes 5884
  out bytes 11339          dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 30        out bcast bytes 10299
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:33:41, last time pvc status changed 00:32:41

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.103

  input pkts 8             output pkts 20           in bytes 2768
  out bytes 6920           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 20        out bcast bytes 6920
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:33:43, last time pvc status changed 00:32:43
R1#


R2#sh frame-relay map
Serial0/0.201 (up): point-to-point dlci, dlci 201(0xC9,0x3090), broadcast
          status defined, active
Serial0/0.203 (up): point-to-point dlci, dlci 203(0xCB,0x30B0), broadcast
          status defined, active
R2#



R2#sh frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          2            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.201

  input pkts 36            output pkts 32           in bytes 8826
  out bytes 7442           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 17        out bcast bytes 5882
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:21:04, last time pvc status changed 00:20:04

DLCI = 203, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.203

  input pkts 11            output pkts 16           in bytes 3806
  out bytes 5536           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 16        out bcast bytes 5536
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:21:05, last time pvc status changed 00:20:05
R2#



R3#sh frame-relay map
Serial0/0.301 (up): point-to-point dlci, dlci 301(0x12D,0x48D0), broadcast
          status defined, active
Serial0/0.302 (up): point-to-point dlci, dlci 302(0x12E,0x48E0), broadcast
          status defined, active
R3#



R3#sh frame-relay map
Serial0/0.301 (up): point-to-point dlci, dlci 301(0x12D,0x48D0), broadcast
          status defined, active
Serial0/0.302 (up): point-to-point dlci, dlci 302(0x12E,0x48E0), broadcast
          status defined, active
R3#
R3#sh frame
R3#sh frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          2            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.301

  input pkts 21            output pkts 18           in bytes 6056
  out bytes 5018           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 13        out bcast bytes 4498
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:16:06, last time pvc status changed 00:15:06

DLCI = 302, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.302

  input pkts 16            output pkts 14           in bytes 5536
  out bytes 4844           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 14        out bcast bytes 4844
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:16:07, last time pvc status changed 00:15:07
R3#



WAN Frame Relay Point-to-Point

WAN Frame Relay Point-to-Point


R1#sh run int s1/0
Building configuration...

Current configuration : 145 bytes
!
interface Serial1/0
 ip address 10.1.1.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay interface-dlci 102
end

R1#



R2#
R2#sh run int s1/0
Building configuration...

Current configuration : 145 bytes
!
interface Serial1/0
 ip address 10.1.1.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay interface-dlci 201
end

R2#


R1#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 122, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 36            output pkts 36           in bytes 3674
  out bytes 3674           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 1         out bcast bytes 34
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:34:40, last time pvc status changed 00:34:40
R1#

R1#ping 10.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/44/84 ms
R1#



R2#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 221, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 37            output pkts 36           in bytes 3708
  out bytes 3674           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 1         out bcast bytes 34
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:32:50, last time pvc status changed 00:31:33
R2#


R2#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/47/80 ms
R2#



WAN Frame Relay MultiPoint

WAN Frame Relay MultiPoint







R1#

hostname R1
!
interface Serial0/0
 ip address 10.1.1.1 255.255.255.248
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.1.1.2 102 broadcast
 frame-relay map ip 10.1.1.3 103 broadcast
 frame-relay map ip 10.1.1.4 104
 no frame-relay inverse-arp
!

R1#

R2#
R2#
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 no frame-relay inverse-arp
!
interface Serial0/0.221 point-to-point
 ip address 10.1.1.2 255.255.255.248
 snmp trap link-status
 frame-relay interface-dlci 201
!
R2#

R3#

interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 no frame-relay inverse-arp
!
interface Serial0/0.321 point-to-point
 ip address 10.1.1.3 255.255.255.248
 snmp trap link-status
 frame-relay interface-dlci 301
!
R3#

R4#
R4#
interface Serial0/0
 ip address 10.1.1.4 255.255.255.248
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.1.1.1 401

R4#
R4#

//-----------------------------------//

R1#sh fram pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

  input pkts 771           output pkts 30           in bytes 258296
  out bytes 3120           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 12:15:25, last time pvc status changed 12:14:25

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

  input pkts 614           output pkts 0            in bytes 212444
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 12:15:26, last time pvc status changed 12:14:26

DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

  input pkts 10            output pkts 10           in bytes 1040
  out bytes 1040           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 12:15:28, last time pvc status changed 12:14:28
R1#

R1#
R1#sh fram map
Serial0/0 (up): ip 10.1.1.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial0/0 (up): ip 10.1.1.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active
Serial0/0 (up): ip 10.1.1.4 dlci 104(0x68,0x1880), static,
              CISCO, status defined, active
R1#



R2#sh fram pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.221

  input pkts 30            output pkts 775          in bytes 3120
  out bytes 259680         dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 740       out bcast bytes 256040
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 12:18:44, last time pvc status changed 12:17:44
R2#

R3#sh fram pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.321

  input pkts 0             output pkts 620          in bytes 0
  out bytes 214520         dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 620       out bcast bytes 214520
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 10:20:27, last time pvc status changed 10:19:26
R3#

R3#sh fram map
Serial0/0.321 (up): point-to-point dlci, dlci 301(0x12D,0x48D0), broadcast
          status defined, active
R3#




R4#sh fram pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 401, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

  input pkts 10            output pkts 10           in bytes 1040
  out bytes 1040           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:00:02, last time pvc status changed 00:58:59
R4#