2013年7月30日 星期二

EIGRP Manual Route Symmarization






Config EIGRP Route Summary

1.In the EIGRP router configurstion mode ,use no auto-summary command.
2.In the interface configuration mode , use the command:
  ip summary-address eigrp [as number] [network prefix] [network mask]
3.Verify the R2 Router have learning the summary network route!


=========================
Before enable EIGRP manual summary
=========================


R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 4 subnets
D       172.16.4.0 [90/156160] via 192.168.2.2, 00:17:47, FastEthernet0/0
D       172.16.1.0 [90/156160] via 192.168.2.2, 00:17:47, FastEthernet0/0
D       172.16.2.0 [90/156160] via 192.168.2.2, 00:17:47, FastEthernet0/0
D       172.16.3.0 [90/156160] via 192.168.2.2, 00:17:47, FastEthernet0/0

     10.0.0.0/24 is subnetted, 4 subnets
D       10.1.3.0 [90/156160] via 192.168.1.2, 00:00:18, FastEthernet0/1
D       10.1.2.0 [90/156160] via 192.168.1.2, 00:00:18, FastEthernet0/1
D       10.1.1.0 [90/156160] via 192.168.1.2, 00:00:18, FastEthernet0/1
D       10.1.4.0 [90/156160] via 192.168.1.2, 00:00:18, FastEthernet0/1

C    192.168.1.0/24 is directly connected, FastEthernet0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0
R2#
R2#


=========================
After enable EIGRP manual summary
=========================

R2#
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    172.16.0.0/16 [90/156160] via 192.168.2.2, 00:00:12, FastEthernet0/0
     10.0.0.0/16 is subnetted, 1 subnets
D       10.1.0.0 [90/156160] via 192.168.1.2, 00:14:37, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0
R2#
R2#








R1#
=============================
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.1.2.2 255.255.255.0
!
interface Loopback3
 ip address 10.1.3.3 255.255.255.0
!
interface Loopback4
 ip address 10.1.4.4 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.2 255.255.255.0
 ip summary-address eigrp 10 10.1.0.0 255.255.0.0 5
 duplex auto
 speed auto
!
router eigrp 10
 network 10.1.1.0 0.0.0.255
 network 10.1.2.0 0.0.0.255
 network 10.1.3.0 0.0.0.255
 network 10.1.4.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!

=============================


R2#
=============================
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 10
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary
=============================




R3#
=============================
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback1
 ip address 172.16.2.2 255.255.255.0
!
interface Loopback2
 ip address 172.16.3.3 255.255.255.0
!
interface Loopback3
 ip address 172.16.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.0
 ip summary-address eigrp 10 172.16.0.0 255.255.0.0 5
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 10
 network 172.16.1.0 0.0.0.255
 network 172.16.2.0 0.0.0.255
 network 172.16.3.0 0.0.0.255
 network 172.16.4.0 0.0.0.255
 network 192.168.2.0
 no auto-summary
 =============================


2013年7月19日 星期五

EIGRP_static_route_redistribution


Objective
Redistribute static route into EIGRP routing protocol, It is use for IP classless network.


R1#
==============================
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial1/0
 ip address 100.100.100.1 255.255.255.252
 encapsulation ppp
!
router eigrp 10
 network 100.100.100.0 0.0.0.3
 no auto-summary
!
==============================


R2#
==============================
 interface FastEthernet0/0
 ip address 200.200.200.1 255.255.255.252
!
interface Serial1/0
 ip address 100.100.100.2 255.255.255.252
 encapsulation ppp
!
router eigrp 10
 redistribute static
 network 100.100.100.0 0.0.0.3
 network 200.200.200.0 0.0.0.3
 no auto-summary
!
ip route 1.1.1.1 255.255.255.255 100.100.100.1
==============================



R3#
==============================
interface FastEthernet0/0
 ip address 200.200.200.2 255.255.255.252
!
router eigrp 10
 network 200.200.200.0 0.0.0.3
 no auto-summary
!
==============================

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     200.200.200.0/30 is subnetted, 1 subnets
C       200.200.200.0 is directly connected, FastEthernet0/0
     1.0.0.0/32 is subnetted, 1 subnets
D EX    1.1.1.1 [170/2172416] via 200.200.200.1, 00:03:42, FastEthernet0/0
     100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       100.100.100.0/30
           [90/2172416] via 200.200.200.1, 00:03:42, FastEthernet0/0
D       100.100.100.1/32
           [90/2172416] via 200.200.200.1, 00:03:42, FastEthernet0/0
R3#




R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     200.200.200.0/30 is subnetted, 1 subnets
C       200.200.200.0 is directly connected, FastEthernet0/0
     1.0.0.0/32 is subnetted, 1 subnets
S       1.1.1.1 [1/0] via 100.100.100.1
     100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       100.100.100.0/30 is directly connected, Serial1/0
C       100.100.100.1/32 is directly connected, Serial1/0
R2#

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     200.200.200.0/30 is subnetted, 1 subnets
D       200.200.200.0 [90/2172416] via 100.100.100.2, 00:05:03, Serial1/0
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       100.100.100.0/30 is directly connected, Serial1/0
C       100.100.100.2/32 is directly connected, Serial1/0
R1#

EIGRP IP default-network


This lab is use EIGRP ip default-network command , it is only for IP classful network .

R1#
=====================================
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial1/0
 ip address 100.100.100.1 255.255.255.252
 encapsulation ppp
!
router eigrp 10
 network 1.1.1.1 0.0.0.0
 network 100.100.100.0 0.0.0.3
 auto-summary
=====================================



R2#
=====================================
interface FastEthernet0/0
 ip address 200.200.200.1 255.255.255.252
!
interface Serial1/0
 ip address 100.100.100.2 255.255.255.252
 encapsulation ppp
!
router eigrp 10
 network 100.100.100.0 0.0.0.3
 network 200.200.200.0 0.0.0.3
 auto-summary
!
ip default-network 1.0.0.0
=====================================



R3#
=====================================
interface FastEthernet0/0
 ip address 200.200.200.2 255.255.255.252
!
router eigrp 10
 network 192.168.1.0 0.0.0.3
 network 200.200.200.0 0.0.0.3
 auto-summary
!
=====================================




 R1#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    200.200.200.0/24 [90/2172416] via 100.100.100.2, 00:16:04, Serial1/0
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       1.1.1.1/32 is directly connected, Loopback0
D       1.0.0.0/8 is a summary, 00:32:49, Null0
     100.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C       100.100.100.0/30 is directly connected, Serial1/0
D       100.0.0.0/8 is a summary, 00:32:49, Null0
C       100.100.100.2/32 is directly connected, Serial1/0
R1#




R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 100.100.100.1 to network 1.0.0.0

     200.200.200.0/24 is variably subnetted, 2 subnets, 2 masks
C       200.200.200.0/30 is directly connected, FastEthernet0/0
D       200.200.200.0/24 is a summary, 00:14:25, Null0
D*   1.0.0.0/8 [90/2297856] via 100.100.100.1, 00:31:09, Serial1/0
     100.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C       100.100.100.0/30 is directly connected, Serial1/0
D       100.0.0.0/8 is a summary, 00:14:25, Null0
C       100.100.100.1/32 is directly connected, Serial1/0
R2#



R3#
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 200.200.200.1 to network 1.0.0.0

     200.200.200.0/30 is subnetted, 1 subnets
C       200.200.200.0 is directly connected, FastEthernet0/0
D*   1.0.0.0/8 [90/2300416] via 200.200.200.1, 00:12:51, FastEthernet0/0
D    100.0.0.0/8 [90/2172416] via 200.200.200.1, 00:12:51, FastEthernet0/0
R3#






2013年7月13日 星期六

EIGRP Passive-interface Lab




Lab objective:
Use the passive-interface and passive-interface default command to disalbe EIGRP neighbor establish on some interface that connect to hosts.


Labs step:
1. setup interface ip address in router R1 and R2
2. enable EIGRP protocol in router R1 and R2
3. In R1 router , setup passive-interface fa0/0
4. In R2 router , setup passive-interface default , and no passive-interface s1/0


Router Configurations:

R1#
===============================
hostname R1
!
interface FastEthernet0/0
 ip address 192.168.1.254 255.255.255.0
!
interface Serial1/0
 ip address 10.1.1.1 255.255.255.252
 encapsulation ppp
!
router eigrp 10
 passive-interface FastEthernet0/0
 network 10.1.1.0 0.0.0.3
 network 192.168.1.0
 no auto-summary
===============================



R2#
===============================
hostname R2!
!
interface FastEthernet0/0
 ip address 192.168.2.254 255.255.255.0
!
interface Serial1/0
 ip address 10.1.1.2 255.255.255.252
 encapsulation ppp
!
router eigrp 10
 passive-interface default
 no passive-interface Serial1/0

 network 10.1.1.0 0.0.0.3
 network 192.168.2.0
 no auto-summary
===============================


Router show information
===============================
R1#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.1.2                Se1/0             10 00:34:56   20   200  0  28 
R1#


R1#sh ip route eigrp
D    192.168.2.0/24 [90/2172416] via 10.1.1.2, 00:12:18, Serial1/0
R1#


R1#sh ip protocols
Routing Protocol is "eigrp 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 10
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.1.1.0/30
    192.168.1.0
  Passive Interface(s):
    FastEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:46:47
    10.1.1.2              90      00:12:42
  Distance: internal 90 external 170

R1#
===============================

R2#show ip eig neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.1.1                Se1/0             12 00:39:03   19   200  0  26
R2#


R2#sh ip route eigrp
D    192.168.1.0/24 [90/2172416] via 10.1.1.1, 00:17:26, Serial1/0
R2#


R2#sh ip protocols
Routing Protocol is "eigrp 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 10
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.1.1.0/30
    192.168.2.0
  Passive Interface(s):
    FastEthernet0/0
    FastEthernet0/1
    Serial1/1
    Serial1/2
    Serial1/3
    VoIP-Null0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.1.1              90      00:17:31
  Distance: internal 90 external 170

R2#
===============================










2013年7月10日 星期三

Cisco CCP (CIsco Configuration Professional)

 Install CCP Step

1.Install JAVA JRE 1.6
2.Install CCP program
3.解析度請調增至1024*768
4.需按右鍵以系統管理員身分執行CCP


R1#
R1#
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int fa0/0
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#
R1(config-if)#exit
R1(config)#
R1(config)#
R1(config)#ip http server
R1(config)#ip http authentication local
R1(config)#ip http timeout-policy idle 300 life 86400 requests 1000
R1(config)#username jerry privilege 15 secret abc
R1(config)#
R1(config)#
R1(config)#end
R1#
R1#



2013年7月9日 星期二

IPv6 Routing RIPng


R1#
=============================
hostname R1
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1:1:1::1/64
 ipv6 enable

 ipv6 rip 10 enable

!
interface Serial1/0
 no ip address
 ipv6 address 2001:2:2:2::1/64
 ipv6 enable

 ipv6 rip 10 enable

!
ipv6 router rip 10
=============================


R2#
=============================
hostname R2
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:3:3:3::1/64
 ipv6 enable

 ipv6 rip 10 enable
!
interface Serial1/0
 no ip address
 ipv6 address 2001:2:2:2::2/64
 ipv6 enable

 ipv6 rip 10 enable
!
ipv6 router rip 10
============================= 


R1#sh ipv6 route rip
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
R   2001:3:3:3::/64 [120/2]
     via FE80::C801:3EFF:FE20:8, Serial1/0
R1#

R1#sh ipv6 rip database
RIP process "10", local RIB
 2001:2:2:2::/64, metric 2
     Serial1/0/FE80::C801:3EFF:FE20:8, expires in 167 secs
 2001:3:3:3::/64, metric 2, installed
     Serial1/0/FE80::C801:3EFF:FE20:8, expires in 167 secs
R1#

R2#sh ipv6 route rip
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
R   2001:1:1:1::/64 [120/2]
     via FE80::C800:3EFF:FE20:8, Serial1/0
R2#

R2#sh ipv6 rip database
RIP process "10", local RIB
 2001:1:1:1::/64, metric 2, installed
     Serial1/0/FE80::C800:3EFF:FE20:8, expires in 151 secs
 2001:2:2:2::/64, metric 2
     Serial1/0/FE80::C800:3EFF:FE20:8, expires in 151 secs
R2#

2013年7月7日 星期日

OSPF MD5 Authentication (enable for area)


Operation step:
 1. Config  OSPF authertication , enable for area
 2. Config MD5 key id , and authentication password

R1#
=====================================
hostname R1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 10.2.2.2 255.255.255.255
!
interface Loopback2
 ip address 10.3.3.3 255.255.255.255
!
interface Serial1/0
 ip address 172.16.1.1 255.255.255.252
 encapsulation ppp
 ip ospf message-digest-key 1 md5 mykey

!
router ospf 1
 log-adjacency-changes
area 0 authentication message-digest
 network 10.1.1.1 0.0.0.0 area 0
 network 10.2.2.2 0.0.0.0 area 0
 network 10.3.3.3 0.0.0.0 area 0
 network 172.16.1.0 0.0.0.3 area 0
=====================================


R2#
=====================================
 hostname R2
!
interface Loopback0
 ip address 10.4.4.4 255.255.255.255
!
interface Loopback1
 ip address 10.5.5.5 255.255.255.255
!
interface Loopback2
 ip address 10.6.6.6 255.255.255.255
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.252
 encapsulation ppp

 ip ospf message-digest-key 1 md5 mykey

!
router ospf 1
 log-adjacency-changes
 area 0 authentication message-digest

 network 10.4.4.4 0.0.0.0 area 0
 network 10.5.5.5 0.0.0.0 area 0
 network 10.6.6.6 0.0.0.0 area 0
 network 172.16.1.0 0.0.0.3 area 0

===================================== 

OSPF MD5 Authentication (enable for interface)


Operation step:
 1. Config  OSPF authertication ,enable for interface
 2. Config MD5 key id , and authentication password


R1#
=====================================
hostname R1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 10.2.2.2 255.255.255.255
!
interface Loopback2
 ip address 10.3.3.3 255.255.255.255
!
interface Serial1/0
 ip address 172.16.1.1 255.255.255.252
 encapsulation ppp
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 mykey

!
router ospf 1
 log-adjacency-changes
 network 10.1.1.1 0.0.0.0 area 0
 network 10.2.2.2 0.0.0.0 area 0
 network 10.3.3.3 0.0.0.0 area 0
 network 172.16.1.0 0.0.0.3 area 0
=====================================


 R2#
=====================================
 hostname R2
!
interface Loopback0
 ip address 10.4.4.4 255.255.255.255
!
interface Loopback1
 ip address 10.5.5.5 255.255.255.255
!
interface Loopback2
 ip address 10.6.6.6 255.255.255.255
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.252
 encapsulation ppp
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 mykey

!
router ospf 1
 log-adjacency-changes
 network 10.4.4.4 0.0.0.0 area 0
 network 10.5.5.5 0.0.0.0 area 0
 network 10.6.6.6 0.0.0.0 area 0
 network 172.16.1.0 0.0.0.3 area 0
===================================== 



R1#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
  Internet Address 172.16.1.1/30, Area 0
  Process ID 1, Router ID 172.16.1.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.6.6.6
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
    Youngest key id is 1

R1#

R1#sh ip ospf nei
Neighbor ID     Pri   State           Dead Time   Address         Interface
10.6.6.6          0   FULL/  -        00:00:33    172.16.1.2      Serial1/0
R1#

2013年7月5日 星期五

EIGRP Authentication

  

LAB Step :
1. setup interface ip address
2. setup EIGRP AS number , and network address
3. in the interface , setup EIGRP authentication mode : MD5 , and setup the keystring
4.create the key chain name : my_keychain
5.setup key-string : mykey

=================================
hostname R1
!
key chain my_keychain
 key 1
   key-string mykey

!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 10.2.2.2 255.255.255.255
!
interface Loopback2
 ip address 10.3.3.3 255.255.255.255
!
interface Serial1/0
 ip address 172.16.1.1 255.255.255.252
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 my_keychain

!
router eigrp 10
 network 10.1.1.1 0.0.0.0
 network 10.2.2.2 0.0.0.0
 network 10.3.3.3 0.0.0.0
 network 172.16.1.0 0.0.0.3
 no auto-summary
!
=================================


=================================
hostname R2
!
key chain my_keychain
 key 1
   key-string mykey

!
interface Loopback0
 ip address 10.4.4.4 255.255.255.255
!
interface Loopback1
 ip address 10.5.5.5 255.255.255.255
!
interface Loopback6
 ip address 10.6.6.6 255.255.255.255
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.252
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 my_keychain

!
router eigrp 10
 network 10.4.4.4 0.0.0.0
 network 10.5.5.5 0.0.0.0
 network 10.6.6.6 0.0.0.0
 network 172.16.1.0 0.0.0.3
 no auto-summary
!
=================================

2013年7月2日 星期二

EIGRP over Frame-Relay MultiPoint Physical Interface



Note:

This is Frame-Relay Hub and Spoke Topology , R1 is "Hub" Router , so R1 must to disable the ip split-horizon , use the "no ip split-horizon eigrp 100" command.

 The Frame-Relay PVC has full mash.


 =================================================
R1#
R1#
!
hostname R1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
!
interface Serial1/0
 ip address 10.1.1.1 255.255.255.0
 encapsulation frame-relay
 no ip split-horizon eigrp 100
 frame-relay map ip 10.1.1.4 104 broadcast
 frame-relay map ip 10.1.1.3 103 broadcast
 frame-relay map ip 10.1.1.2 102 broadcast
!
!
router eigrp 100
 network 1.1.1.1 0.0.0.0
 network 10.1.1.0 0.0.0.255
 no auto-summary
!
R1#
=================================================


=================================================
R2#
R2#
!
hostname R2
!
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
!

interface Serial1/0
 ip address 10.1.1.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.1 201 broadcast
!

router eigrp 100
 network 1.1.1.2 0.0.0.0
 network 10.1.1.0 0.0.0.255
 no auto-summary
!

R2#
R2#
=================================================


=================================================
R3#
!
hostname R3
!
!
interface Loopback0
 ip address 1.1.1.3 255.255.255.255
!
!
interface Serial1/0
 ip address 10.1.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.1 301 broadcast
!
router eigrp 100
 network 1.1.1.3 0.0.0.0
 network 10.1.1.0 0.0.0.255
 no auto-summary
!
=================================================


=================================================
R4#
R4#
!
hostname R4
!
interface Loopback0
 ip address 1.1.1.4 255.255.255.255
!
!
interface Serial1/0
 ip address 10.1.1.4 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.1 401 broadcast
!
router eigrp 100
 network 1.1.1.4 0.0.0.0
 network 10.1.1.0 0.0.0.255
 no auto-summary
!
=================================================



=================================================

R1#ping 1.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/75/108 ms
R1#ping 1.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/53/92 ms
R1#ping 1.1.1.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/56/124 ms
R1#
R1#show frame-relay map
Serial1/0 (up): ip 10.1.1.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 10.1.1.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 10.1.1.4 dlci 104(0x68,0x1880), static,
              broadcast,
              CISCO, status defined, active
R1#
R1#
R1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 127           output pkts 132          in bytes 8462
  out bytes 8856           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 108       out bcast bytes 6912
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:36:05, last time pvc status changed 01:34:26

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 123           output pkts 128          in bytes 8128
  out bytes 8437           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 108       out bcast bytes 6912
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:36:06, last time pvc status changed 01:34:27

DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 136           output pkts 138          in bytes 9120
  out bytes 9562           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 108       out bcast bytes 6912
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:36:06, last time pvc status changed 01:34:28
R1#

R1#
R1#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 580              Num Status msgs Rcvd 577
  Num Update Status Rcvd 0              Num Status Timeouts 3
  Last Full Status Req 00:00:00         Last Full Status Rcvd 00:00:00
R1#
R1#
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   10.1.1.2                Se1/0            136 01:34:27  399  2394  0  15
1   10.1.1.4                Se1/0            170 01:34:27  153   918  0  15
0   10.1.1.3                Se1/0            149 01:34:27  295  1770  0  15
R1#
R1#
R1#
R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(1.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 1.1.1.1/32, 1 successors, FD is 128256
        via Connected, Loopback0
P 1.1.1.3/32, 1 successors, FD is 2297856
        via 10.1.1.3 (2297856/128256), Serial1/0
P 1.1.1.2/32, 1 successors, FD is 2297856
        via 10.1.1.2 (2297856/128256), Serial1/0
P 1.1.1.4/32, 1 successors, FD is 2297856
        via 10.1.1.4 (2297856/128256), Serial1/0
P 10.1.1.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/0
R1#

R1#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 4 subnets
C       1.1.1.1 is directly connected, Loopback0
D       1.1.1.3 [90/2297856] via 10.1.1.3, 01:34:55, Serial1/0
D       1.1.1.2 [90/2297856] via 10.1.1.2, 01:34:55, Serial1/0
D       1.1.1.4 [90/2297856] via 10.1.1.4, 01:28:14, Serial1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial1/0
R1#
R1#

=================================================


=================================================

R2#
R2#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/109/164 ms
R2#ping 1.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/79/96 ms
R2#ping 1.1.1.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/67/104 ms
R2#
R2#
R2#show frame-relay map
Serial1/0 (up): ip 10.1.1.1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 10.1.1.3 dlci 203(0xCB,0x30B0), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 10.1.1.4 dlci 204(0xCC,0x30C0), dynamic,
              broadcast,, status defined, active
R2#
R2#
R2#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 109           output pkts 105          in bytes 7184
  out bytes 6854           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 88        out bcast bytes 5632
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:19:57, last time pvc status changed 01:18:17

DLCI = 203, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 109           output pkts 106          in bytes 6890
  out bytes 6789           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 90        out bcast bytes 5640
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:18:19, last time pvc status changed 01:18:19

DLCI = 204, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 123           output pkts 119          in bytes 8378
  out bytes 8232           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 90        out bcast bytes 5640
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:18:19, last time pvc status changed 01:18:19
R2#

R2#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 481              Num Status msgs Rcvd 478
  Num Update Status Rcvd 0              Num Status Timeouts 3
  Last Full Status Req 00:00:32         Last Full Status Rcvd 00:00:32
R2#
R2#


R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   10.1.1.1                Se1/0            170 01:17:59  984  5000  0  18
1   10.1.1.4                Se1/0            168 01:17:59  425  2550  0  15
0   10.1.1.3                Se1/0            140 01:17:59  451  2706  0  15
R2#
R2#
R2#sh ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(1.1.1.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 1.1.1.1/32, 1 successors, FD is 2297856
        via 10.1.1.1 (2297856/128256), Serial1/0
P 1.1.1.3/32, 1 successors, FD is 2297856
        via 10.1.1.3 (2297856/128256), Serial1/0
P 1.1.1.2/32, 1 successors, FD is 128256
        via Connected, Loopback0
P 1.1.1.4/32, 1 successors, FD is 2297856
        via 10.1.1.4 (2297856/128256), Serial1/0
P 10.1.1.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/0
R2#

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 4 subnets
D       1.1.1.1 [90/2297856] via 10.1.1.1, 01:18:29, Serial1/0
D       1.1.1.3 [90/2297856] via 10.1.1.3, 01:18:30, Serial1/0
C       1.1.1.2 is directly connected, Loopback0
D       1.1.1.4 [90/2297856] via 10.1.1.4, 01:11:49, Serial1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial1/0
R2#
R2#

=================================================


=================================================
R3#
R3#
R3#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/52/140 ms
R3#ping 1.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/66/124 ms
R3#ping 1.1.1.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/62/100 ms
R3#
R3#
R3#show frame-relay map
Serial1/0 (up): ip 10.1.1.1 dlci 301(0x12D,0x48D0), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 10.1.1.2 dlci 302(0x12E,0x48E0), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 10.1.1.4 dlci 304(0x130,0x4C00), dynamic,
              broadcast,, status defined, active
R3#
R3#
R3#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 137           output pkts 132          in bytes 9213
  out bytes 8904           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 109       out bcast bytes 6976
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:39:44, last time pvc status changed 01:38:05

DLCI = 302, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 136           output pkts 133          in bytes 8789
  out bytes 8686           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 112       out bcast bytes 7018
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:38:06, last time pvc status changed 01:38:06

DLCI = 304, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 159           output pkts 154          in bytes 11292
  out bytes 11177          dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 111       out bcast bytes 6984
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:38:06, last time pvc status changed 01:38:06
R3#


R3#
R3#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 601              Num Status msgs Rcvd 598
  Num Update Status Rcvd 0              Num Status Timeouts 3
  Last Full Status Req 00:00:33         Last Full Status Rcvd 00:00:33
R3#
R3#
R3#
R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   10.1.1.1                Se1/0            125 01:37:57  852  5000  0  18
1   10.1.1.2                Se1/0            145 01:37:57  901  5000  0  15
0   10.1.1.4                Se1/0            132 01:37:57  969  5000  0  15
R3#
R3#

R3#
R3#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(1.1.1.3)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 1.1.1.1/32, 1 successors, FD is 2297856
        via 10.1.1.1 (2297856/128256), Serial1/0
P 1.1.1.3/32, 1 successors, FD is 128256
        via Connected, Loopback0
P 1.1.1.2/32, 1 successors, FD is 2297856
        via 10.1.1.2 (2297856/128256), Serial1/0
P 1.1.1.4/32, 1 successors, FD is 2297856
        via 10.1.1.4 (2297856/128256), Serial1/0
P 10.1.1.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/0
R3#
R3#
R3#
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 4 subnets
D       1.1.1.1 [90/2297856] via 10.1.1.1, 01:38:18, Serial1/0
C       1.1.1.3 is directly connected, Loopback0
D       1.1.1.2 [90/2297856] via 10.1.1.2, 01:38:17, Serial1/0
D       1.1.1.4 [90/2297856] via 10.1.1.4, 01:31:36, Serial1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial1/0
R3#
=================================================


=================================================

R4#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/78/164 ms
R4#ping 1.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/61/120 ms
R4#ping 1.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/58/68 ms
R4#

R4#show frame-relay map
Serial1/0 (up): ip 10.1.1.1 dlci 401(0x191,0x6410), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 10.1.1.2 dlci 402(0x192,0x6420), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): ip 10.1.1.3 dlci 403(0x193,0x6430), dynamic,
              broadcast,, status defined, active
R4#
R4#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 401, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 155           output pkts 153          in bytes 10850
  out bytes 10408          dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 118       out bcast bytes 7552
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:47:23, last time pvc status changed 01:45:44

DLCI = 402, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 164           output pkts 161          in bytes 11362
  out bytes 11270          dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 121       out bcast bytes 7594
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:45:45, last time pvc status changed 01:45:45

DLCI = 403, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 179           output pkts 176          in bytes 13016
  out bytes 12859          dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 121       out bcast bytes 7594
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:45:48, last time pvc status changed 01:45:48
R4#

R4#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 647              Num Status msgs Rcvd 644
  Num Update Status Rcvd 0              Num Status Timeouts 3
  Last Full Status Req 00:00:10         Last Full Status Rcvd 00:00:10
R4#
R4#
R4#

R4#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   10.1.1.1                Se1/0            162 01:45:37 1015  5000  0  18
1   10.1.1.2                Se1/0            134 01:45:37  615  3690  0  15
0   10.1.1.3                Se1/0            153 01:45:37  314  1884  0  16
R4#
R4#
R4#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(10.1.1.4)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 1.1.1.1/32, 1 successors, FD is 2297856
        via 10.1.1.1 (2297856/128256), Serial1/0
P 1.1.1.3/32, 1 successors, FD is 2297856
        via 10.1.1.3 (2297856/128256), Serial1/0
P 1.1.1.2/32, 1 successors, FD is 2297856
        via 10.1.1.2 (2297856/128256), Serial1/0
P 1.1.1.4/32, 1 successors, FD is 128256
        via Connected, Loopback0
P 10.1.1.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/0
R4#
R4#
R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 4 subnets
D       1.1.1.1 [90/2297856] via 10.1.1.1, 00:05:08, Serial1/0
D       1.1.1.3 [90/2297856] via 10.1.1.3, 01:45:56, Serial1/0
D       1.1.1.2 [90/2297856] via 10.1.1.2, 00:05:08, Serial1/0
C       1.1.1.4 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial1/0
R4#
R4#

=================================================