IPv6 / DHCPv6 Server Statless
=====================
PC0 IP Info
=====================
PC1 IP Info
=====================
R1#show ipv6 dhcp interface
GigabitEthernet0/0 is in server mode
Using pool: mypool
Preference value: 0
Hint from client: ignored
Rapid-Commit: disabled
R1#
R1#show ipv6 dhcp pool
DHCPv6 pool: mypool
DNS server: 2001:DB8::1
Domain name: fff.com
Active clients: 0
R1#
R1#show ipv6 dhcp binding
Client: 0001.6395.2410 (GigabitEthernet0/0)
DUID: 00030001000163952410
IA PD: IA ID 0, T1 0, T2 0
Prefix: 0.0.0.0/0
preferred lifetime 0, valid lifetime 0
expires at ?? 18 2016 2:39:56 pm (0 seconds)
Client: 00D0.D357.E21B (GigabitEthernet0/0)
DUID: 0003000100D0D357E21B
IA PD: IA ID 0, T1 0, T2 0
Prefix: 0.0.0.0/0
preferred lifetime 0, valid lifetime 0
expires at ?? 18 2016 2:39:56 pm (0 seconds)
R1#
=====================
R1#sh run
Building configuration...
Current configuration : 711 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
ipv6 unicast-routing
!
!
ipv6 dhcp pool mypool
dns-server 2001:DB8::1
domain-name fff.com
!
!
!
!
!
!
license udi pid CISCO2901/K9 sn FTX15248605
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001::1/64
ipv6 nd other-config-flag
ipv6 enable
ipv6 dhcp server mypool
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
R1#
R1#
R1#
=====================
2016年2月18日 星期四
IPv6 / DHCPv6 Server Stateful
IPv6 / DHCPv6 Server Stateful
==========================
PC0 IP Info :
==========================
PC1 IP Info :
==========================
R1#show ipv6 dhcp interface
GigabitEthernet0/0 is in server mode
Using pool: mypool
Preference value: 0
Hint from client: ignored
Rapid-Commit: disabled
R1#
R1#
R1#
R1#show ipv6 dhcp pool
DHCPv6 pool: mypool
Prefix pool: local-pool
preferred lifetime 1800, valid lifetime 600
DNS server: 2001:DB8::1
Domain name: fff.com
Active clients: 2
R1#
R1#
R1#
R1#show ipv6 dhcp binding
Client: 0001.6395.2410 (GigabitEthernet0/0)
DUID: 00030001000163952410
IA PD: IA ID 0, T1 0, T2 0
Prefix: 2001::/64
preferred lifetime 1800, valid lifetime 600
expires at ?? 18 2016 11:44:27 am (600 seconds)
Client: 00D0.D357.E21B (GigabitEthernet0/0)
DUID: 0003000100D0D357E21B
IA PD: IA ID 0, T1 0, T2 0
Prefix: 2001::/64
preferred lifetime 1800, valid lifetime 600
expires at ?? 18 2016 11:44:27 am (600 seconds)
R1#
R1#
==========================
R1#sh run
Building configuration...
Current configuration : 777 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
ipv6 unicast-routing
!
!
ipv6 dhcp pool mypool
prefix-delegation pool local-pool lifetime 1800 600
dns-server 2001:DB8::1
domain-name fff.com
!
ipv6 local pool local-pool 2001::/64 64
!
!
!
!
!
license udi pid CISCO2901/K9 sn FTX15248605
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001::1/64
ipv6 enable
ipv6 dhcp server mypool
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
R1#
==========================
==========================
PC0 IP Info :
==========================
PC1 IP Info :
==========================
R1#show ipv6 dhcp interface
GigabitEthernet0/0 is in server mode
Using pool: mypool
Preference value: 0
Hint from client: ignored
Rapid-Commit: disabled
R1#
R1#
R1#
R1#show ipv6 dhcp pool
DHCPv6 pool: mypool
Prefix pool: local-pool
preferred lifetime 1800, valid lifetime 600
DNS server: 2001:DB8::1
Domain name: fff.com
Active clients: 2
R1#
R1#
R1#
R1#show ipv6 dhcp binding
Client: 0001.6395.2410 (GigabitEthernet0/0)
DUID: 00030001000163952410
IA PD: IA ID 0, T1 0, T2 0
Prefix: 2001::/64
preferred lifetime 1800, valid lifetime 600
expires at ?? 18 2016 11:44:27 am (600 seconds)
Client: 00D0.D357.E21B (GigabitEthernet0/0)
DUID: 0003000100D0D357E21B
IA PD: IA ID 0, T1 0, T2 0
Prefix: 2001::/64
preferred lifetime 1800, valid lifetime 600
expires at ?? 18 2016 11:44:27 am (600 seconds)
R1#
R1#
==========================
R1#sh run
Building configuration...
Current configuration : 777 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
ipv6 unicast-routing
!
!
ipv6 dhcp pool mypool
prefix-delegation pool local-pool lifetime 1800 600
dns-server 2001:DB8::1
domain-name fff.com
!
ipv6 local pool local-pool 2001::/64 64
!
!
!
!
!
license udi pid CISCO2901/K9 sn FTX15248605
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001::1/64
ipv6 enable
ipv6 dhcp server mypool
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
R1#
==========================
DHCP Relay
DHCP Relay
====================
DHCP Server Pool
====================
PC0 : ip info
====================
PC1 : ip info
====================
Router#sh run
!
hostname Router
!
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip helper-address 10.0.0.1
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.254 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
ip address 192.168.2.254 255.255.255.0
ip helper-address 10.0.0.1
duplex auto
speed auto
!
Router#
====================
====================
DHCP Server Pool
====================
PC0 : ip info
====================
PC1 : ip info
====================
Router#sh run
!
hostname Router
!
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip helper-address 10.0.0.1
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.254 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
ip address 192.168.2.254 255.255.255.0
ip helper-address 10.0.0.1
duplex auto
speed auto
!
Router#
====================
2016年2月17日 星期三
Enable NAT(PAT) on DHCP Server
Enable NAT(PAT) on DHCP Server
=========================
PC>ping 192.168.3.10
Pinging 192.168.3.10 with 32 bytes of data:
Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
Ping statistics for 192.168.3.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms
PC>
=========================
R1#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 10.0.0.1:5 192.168.1.10:5 192.168.3.10:5 192.168.3.10:5
icmp 10.0.0.1:6 192.168.1.10:6 192.168.3.10:6 192.168.3.10:6
icmp 10.0.0.1:7 192.168.1.10:7 192.168.3.10:7 192.168.3.10:7
icmp 10.0.0.1:8 192.168.1.10:8 192.168.3.10:8 192.168.3.10:8
icmp 10.0.0.1:10 192.168.2.10:10 192.168.3.10:10 192.168.3.10:10
icmp 10.0.0.1:11 192.168.2.10:11 192.168.3.10:11 192.168.3.10:11
icmp 10.0.0.1:12 192.168.2.10:12 192.168.3.10:12 192.168.3.10:12
icmp 10.0.0.1:9 192.168.2.10:9 192.168.3.10:9 192.168.3.10:9
R1#
=========================
R1#sh ip nat statistics
Total translations: 0 (0 static, 0 dynamic, 0 extended)
Outside Interfaces: Serial0/0/0
Inside Interfaces: FastEthernet0/0 , FastEthernet0/1
Hits: 19 Misses: 20
Expired translations: 20
Dynamic mappings:
-- Inside Source
access-list 10 pool mypool refCount 0
pool mypool: netmask 255.255.255.252
start 10.0.0.1 end 10.0.0.1
type generic, total addresses 1 , allocated 0 (0%), misses 0
R1#
=========================
R1#show ip dhcp binding
IP address Client-ID/ Lease expiration Type
Hardware address
192.168.1.10 0001.C706.A76A -- Automatic
192.168.2.10 0001.4348.BE92 -- Automatic
R1#
R1#
=========================
R1#sh run
!
hostname R1
!
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.9
ip dhcp excluded-address 192.168.2.1 192.168.2.9
!
ip dhcp pool mydhcp
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 8.8.8.8
ip dhcp pool mydhcp2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.254
dns-server 8.8.8.8
!
!
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.0.0.1 255.255.255.252
ip nat outside
!
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0.0.0.0
network 192.168.2.0 0.0.0.255 area 0.0.0.0
network 10.0.0.0 0.0.0.3 area 0.0.0.0
!
ip nat pool mypool 10.0.0.1 10.0.0.1 netmask 255.255.255.252
ip nat inside source list 10 pool mypool overload
ip classless
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.2.0 0.0.0.255
!
!
end
R1#
=========================
R2#sh run
!
hostname R2
!
interface GigabitEthernet0/0
ip address 192.168.3.254 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 10.0.0.2 255.255.255.252
!
router ospf 1
log-adjacency-changes
network 192.168.3.0 0.0.0.255 area 0.0.0.0
network 10.0.0.0 0.0.0.3 area 0.0.0.0
!
end
R2#
=========================
=========================
PC>ping 192.168.3.10
Pinging 192.168.3.10 with 32 bytes of data:
Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
Ping statistics for 192.168.3.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms
PC>
=========================
R1#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 10.0.0.1:5 192.168.1.10:5 192.168.3.10:5 192.168.3.10:5
icmp 10.0.0.1:6 192.168.1.10:6 192.168.3.10:6 192.168.3.10:6
icmp 10.0.0.1:7 192.168.1.10:7 192.168.3.10:7 192.168.3.10:7
icmp 10.0.0.1:8 192.168.1.10:8 192.168.3.10:8 192.168.3.10:8
icmp 10.0.0.1:10 192.168.2.10:10 192.168.3.10:10 192.168.3.10:10
icmp 10.0.0.1:11 192.168.2.10:11 192.168.3.10:11 192.168.3.10:11
icmp 10.0.0.1:12 192.168.2.10:12 192.168.3.10:12 192.168.3.10:12
icmp 10.0.0.1:9 192.168.2.10:9 192.168.3.10:9 192.168.3.10:9
R1#
=========================
R1#sh ip nat statistics
Total translations: 0 (0 static, 0 dynamic, 0 extended)
Outside Interfaces: Serial0/0/0
Inside Interfaces: FastEthernet0/0 , FastEthernet0/1
Hits: 19 Misses: 20
Expired translations: 20
Dynamic mappings:
-- Inside Source
access-list 10 pool mypool refCount 0
pool mypool: netmask 255.255.255.252
start 10.0.0.1 end 10.0.0.1
type generic, total addresses 1 , allocated 0 (0%), misses 0
R1#
=========================
R1#show ip dhcp binding
IP address Client-ID/ Lease expiration Type
Hardware address
192.168.1.10 0001.C706.A76A -- Automatic
192.168.2.10 0001.4348.BE92 -- Automatic
R1#
R1#
=========================
R1#sh run
!
hostname R1
!
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.9
ip dhcp excluded-address 192.168.2.1 192.168.2.9
!
ip dhcp pool mydhcp
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 8.8.8.8
ip dhcp pool mydhcp2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.254
dns-server 8.8.8.8
!
!
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.0.0.1 255.255.255.252
ip nat outside
!
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0.0.0.0
network 192.168.2.0 0.0.0.255 area 0.0.0.0
network 10.0.0.0 0.0.0.3 area 0.0.0.0
!
ip nat pool mypool 10.0.0.1 10.0.0.1 netmask 255.255.255.252
ip nat inside source list 10 pool mypool overload
ip classless
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.2.0 0.0.0.255
!
!
end
R1#
=========================
R2#sh run
!
hostname R2
!
interface GigabitEthernet0/0
ip address 192.168.3.254 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 10.0.0.2 255.255.255.252
!
router ospf 1
log-adjacency-changes
network 192.168.3.0 0.0.0.255 area 0.0.0.0
network 10.0.0.0 0.0.0.3 area 0.0.0.0
!
end
R2#
=========================
DHCP Server
======================
R1#show ip dhcp binding
IP address Client-ID/ Lease expiration Type
Hardware address
192.168.1.10 0001.C706.A76A -- Automatic
192.168.2.10 0001.4348.BE92 -- Automatic
R1#
======================
R1#sh run
!
hostname R1
!
ip dhcp excluded-address 192.168.1.1 192.168.1.9
ip dhcp excluded-address 192.168.2.1 192.168.2.9
!
ip dhcp pool mydhcp
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 8.8.8.8
ip dhcp pool mydhcp2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.254
dns-server 8.8.8.8
!
!
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.254 255.255.255.0
duplex auto
speed auto
!
end
R1#
======================
PC1 : IP Info
======================
PC0 : IP Info
======================
2016年2月16日 星期二
GLBP
========================
PC1> trace 172.22.0.10
trace to 172.22.0.10, 8 hops max, press Ctrl+C to stop
1 192.168.1.2 10.729 ms 46.105 ms 43.563 ms
2 10.1.2.2 67.146 ms 70.208 ms 35.733 ms
3 *172.22.0.10 79.383 ms (ICMP type:3, code:3, Destination port unreachable)
PC1> trace 172.22.0.10
trace to 172.22.0.10, 8 hops max, press Ctrl+C to stop
1 192.168.1.1 45.901 ms 45.564 ms 10.267 ms
2 10.1.1.2 32.789 ms 59.528 ms 66.543 ms
3 *172.22.0.10 79.247 ms (ICMP type:3, code:3, Destination port unreachable)
PC1>
========================
========================
========================
R1#sh run
!
hostname R1
!
track 1 interface Serial1/0 line-protocol
!
interface FastEthernet0/0
mac-address aaaa.aaaa.aaaa
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
glbp 100 ip 192.168.1.254
glbp 100 preempt
!
!
interface Serial1/0
ip address 10.1.1.1 255.255.255.252
encapsulation ppp
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
end
R1#
========================
R2#sh run
!
hostname R2
!
!
interface FastEthernet0/0
mac-address cccc.cccc.cccc
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
glbp 100 ip 192.168.1.254
glbp 100 priority 90
glbp 100 preempt
!
!
interface Serial1/0
ip address 10.1.2.1 255.255.255.252
encapsulation ppp
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
end
R2#
========================
R3#sh run
!
hostname R3
!
!
interface FastEthernet0/0
mac-address eeee.eeee.eeee
ip address 172.22.0.1 255.255.255.0
duplex auto
speed auto
glbp 100 ip 172.22.0.254
glbp 100 preempt
!
interface Serial1/0
ip address 10.1.1.2 255.255.255.0
encapsulation ppp
serial restart-delay 0
!
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
end
R3#
========================
R4#sh run
!
hostname R4
!
interface FastEthernet0/0
mac-address aaaa.aaaa.aaaa
ip address 172.22.0.2 255.255.255.0
duplex auto
speed auto
glbp 100 ip 172.22.0.254
glbp 100 priority 90
glbp 100 preempt
!
!
interface Serial1/0
ip address 10.1.2.2 255.255.255.252
encapsulation ppp
!
!
router ospf 1
log-adjacency-changes
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
R4#
========================
PAT (Port Address Translation)
==========================
R2#
R2#sh run
!
hostname R2
!
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 100.1.1.1 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
!
ip nat pool pat 100.1.1.1 100.1.1.1 netmask 255.255.255.0
ip nat inside source list 10 pool pat overload
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
!
end
R2#
====================================================
R1#sh run
!
hostname R1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 100.1.1.2 255.255.255.0
duplex auto
speed auto
!
ip route 192.168.1.0 255.255.255.0 100.1.1.1
R1#
==========================2016年2月3日 星期三
VRRP track on ethernet
VRRP track on ethernet
=================================
=================================
=================================
=================================
=================================
=================================
=================================
R1#sh run
!
hostname R1
!
!
track 1 rtr 1
!
interface FastEthernet0/0
ip address 192.168.1.250 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 192.168.1.254
vrrp 1 priority 110
vrrp 1 authentication md5 key-string 123
vrrp 1 track 1 decrement 50
!
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
ip sla 1
icmp-echo 10.1.1.2 source-interface FastEthernet0/1
frequency 5
ip sla schedule 1 life forever start-time now
!
!
R1#
=================================
=================================
R2#sh run
!
hostname R2
!
track 1 rtr 1
!
interface FastEthernet0/0
ip address 192.168.1.251 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 192.168.1.254
vrrp 1 authentication md5 key-string 123
vrrp 1 track 1 decrement 50
!
interface FastEthernet0/1
ip address 10.1.2.1 255.255.255.252
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
ip sla 1
icmp-echo 10.1.2.2 source-interface FastEthernet0/1
frequency 5
ip sla schedule 1 life forever start-time now
!
end
R2#
=================================
=================================
R3#
R3#
R3#sh run
!
hostname R3
!
!
track 1 rtr 1
!
!
interface FastEthernet0/0
ip address 172.22.0.250 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 172.22.0.254
vrrp 1 priority 110
vrrp 1 authentication md5 key-string 123
vrrp 1 track 1 decrement 50
!
interface FastEthernet0/1
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
!
ip sla 1
icmp-echo 10.1.1.1 source-interface FastEthernet0/1
frequency 5
ip sla schedule 1 life forever start-time now
!
!
end
R3#
==================================================================
R4#sh run
!
hostname R4
!
!
interface FastEthernet0/0
ip address 172.22.0.251 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 172.22.0.254
vrrp 1 authentication md5 key-string 123
!
interface FastEthernet0/1
ip address 10.1.2.2 255.255.255.252
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
!
ip sla 1
icmp-echo 10.1.2.1 source-interface FastEthernet0/1
frequency 5
ip sla schedule 1 life forever start-time now
!
end
R4#
=================================HSRP track on ethernet
hsrp track on ethernet
==================================
==================================
==================================
==================================
==================================
==================================
R1#
R1#sh run
version 12.4
!
hostname R1
!
!
ip tcp synwait-time 5
!
track 1 rtr 1
!
interface FastEthernet0/0
ip address 192.168.1.250 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.1.254
standby 1 priority 110
standby 1 preempt
standby 1 authentication md5 key-string 123
standby 1 track 1 decrement 50
!
interface FastEthernet0/1
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
!
ip sla 1
icmp-echo 10.1.1.2 source-interface FastEthernet0/1
frequency 5
ip sla schedule 1 life forever start-time now
!
webvpn cef
!
end
R1#
==================================
==================================
R2#
R2#sh run
Building configuration...
!
hostname R2
!
!
track 1 rtr 1
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.251 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.1.254
standby 1 preempt
standby 1 authentication md5 key-string 123
standby 1 track 1 decrement 50
!
interface FastEthernet0/1
ip address 10.1.2.1 255.255.255.252
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
!
ip sla 1
icmp-echo 10.1.2.2 source-interface FastEthernet0/1
frequency 5
ip sla schedule 1 life forever start-time now
!
!
end
R2#
==================================
==================================
R3#sh run
!
hostname R3
!
track 1 rtr 1
!
interface FastEthernet0/0
ip address 172.22.0.250 255.255.255.0
duplex auto
speed auto
standby 1 ip 172.22.0.254
standby 1 priority 110
standby 1 preempt
standby 1 authentication md5 key-string 123
standby 1 track 1 decrement 50
!
interface FastEthernet0/1
ip address 10.1.1.2 255.255.255.252
shutdown
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
!
ip sla 1
icmp-echo 10.1.1.1 source-interface FastEthernet0/1
frequency 5
ip sla schedule 1 life forever start-time now
!
end
R3#
==================================
==================================
R4#sh run
!
hostname R4
!
track 1 rtr 1
!
interface FastEthernet0/0
ip address 172.22.0.251 255.255.255.0
duplex auto
speed auto
standby 1 ip 172.22.0.254
standby 1 preempt
standby 1 authentication md5 key-string 123
!
interface FastEthernet0/1
ip address 10.1.2.2 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
!
ip sla 1
icmp-echo 10.1.2.1 source-interface FastEthernet0/1
frequency 5
ip sla schedule 1 life forever start-time now
!
end
R4#
==================================
HSRP track on serial
HSRP track on serial interface
===============================
===============================
===============================
===============================
===============================
===============================
R1#sh run
Building configuration...
Current configuration : 1589 bytes
!
!
hostname R1
!
track 1 interface Serial1/0 line-protocol
!
interface FastEthernet0/0
ip address 192.168.1.250 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.1.254
standby 1 priority 110
standby 1 preempt
standby 1 authentication md5 key-string 123
standby 1 track 1 decrement 50
!!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
end
R1#
===============================
===============================
R2#sh run
Building configuration...
!
hostname R2
!
track 1 interface Serial1/0 line-protocol
!
interface FastEthernet0/0
ip address 192.168.1.251 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.1.254
standby 1 preempt
standby 1 authentication md5 key-string 123
standby 1 track 1 decrement 50
!
interface Serial1/0
ip address 10.1.2.1 255.255.255.252
encapsulation ppp
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
!
end
R2#
==============================================================
R3#sh run
Building configuration...
!
hostname R3
!
track 1 interface Serial1/0 line-protocol
!
interface FastEthernet0/0
ip address 172.22.0.250 255.255.255.0
duplex auto
speed auto
standby 1 ip 172.22.0.254
standby 1 priority 110
standby 1 preempt
standby 1 authentication md5 key-string 123
standby 1 track 1 decrement 50
!
!
interface Serial1/0
ip address 10.1.1.2 255.255.255.0
encapsulation ppp
serial restart-delay 0
!
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
!
end
R3#
==============================================================
R4#
R4#sh run
!
hostname R4
!
track 1 interface Serial1/0 line-protocol
!
interface FastEthernet0/0
ip address 172.22.0.251 255.255.255.0
duplex auto
speed auto
standby 1 ip 172.22.0.254
standby 1 preempt
standby 1 authentication md5 key-string 123
standby 1 track 1 decrement 50
!
interface Serial1/0
ip address 10.1.2.2 255.255.255.252
encapsulation ppp
serial restart-delay 0
!
!
router ospf 1
log-adjacency-changes
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
R4#
===============================VRRP track on serial
VRRP track on serial interface
============================
============================
hostname R1
!
track 1 interface Serial1/0 line-protocol
!
interface FastEthernet0/0
ip address 192.168.1.250 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 192.168.1.254
vrrp 1 priority 110
vrrp 1 authentication md5 key-string 123
vrrp 1 track 1 decrement 50
!
interface Serial1/0
ip address 10.1.1.1 255.255.255.252
encapsulation ppp
!
router ospf 1
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
end
============================
============================
hostname R2
!
track 1 interface Serial1/0 line-protocol
!
interface FastEthernet0/0
ip address 192.168.1.251 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 192.168.1.254
vrrp 1 priority 100
vrrp 1 authentication md5 key-string 123
vrrp 1 track 1 decrement 50
!
interface Serial1/0
ip address 10.1.2.1 255.255.255.252
encapsulation ppp
!
router ospf 1
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 192.168.1.0 0.0.0.255 area 0.0.0.0
!
end
============================
============================
hostname R3
!
track 1 interface Serial1/0 line-protocol
!
interface FastEthernet0/0
ip address 172.22.0.250 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 172.22.0.254
vrrp 1 priority 110
vrrp 1 authentication md5 key-string 123
vrrp 1 track 1 decrement 50
!
interface Serial1/0
ip address 10.1.1.2 255.255.255.252
encapsulation ppp
!
router ospf 1
network 10.1.1.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
end
============================
============================
hostname R4
!
track 1 interface Serial1/0 line-protocol
!
interface FastEthernet0/0
ip address 172.22.0.251 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 172.22.0.254
vrrp 1 priority 100
vrrp 1 authentication md5 key-string 123
vrrp 1 track 1 decrement 50
!
interface Serial1/0
ip address 10.1.2.2 255.255.255.252
encapsulation ppp
!
router ospf 1
network 10.1.2.0 0.0.0.3 area 0.0.0.0
network 172.22.0.0 0.0.0.255 area 0.0.0.0
!
end
============================
訂閱:
文章 (Atom)